diff mbox series

[bug#67902,87/95] gnu: Add php-symfony-var-exporter.

Message ID 20231219140934.22783-87-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:58 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-var-exporter): New variable.

Change-Id: I8b4c6f253dced619e77a84c01dcaf4bcd4b963d4
---
 gnu/packages/php-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 1a2fcba136..6bd9545f1f 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2361,3 +2361,29 @@  (define-public php-symfony-var-dumper
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-var-exporter
+  (package
+    (name "php-symfony-var-exporter")
+    (version "6.3.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/var-exporter")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ca40bggpjj41w92dwikzk1zldr4k1bs677j0c7vmh4kjm8ij939"))))
+    (build-system composer-build-system)
+    (arguments
+     (list
+      #:test-flags ''("--bootstrap" "vendor/autoload.php" "Tests")))
+    (native-inputs
+     (list php-phpunit-phpunit php-symfony-var-dumper))
+    (synopsis "Export PHP data structures to code")
+    (description
+     "This package allows exporting any serializable PHP data structure to
+plain PHP code.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+