diff mbox series

[bug#67902,28/95] gnu: Add php-phpunit-php-timer.

Message ID 20231219140934.22783-28-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpunit-php-timer): New variable.

Change-Id: I4f8cef7408431778a46cb044c181b4620a286ccf
---
 gnu/packages/php-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 3df6f92a2d..046d13b954 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -764,3 +764,26 @@  (define-public php-phpunit-php-invoker
     (home-page "https://github.com/sebastianbergmann/php-invoker/")
     (license license:bsd-3)))
 
+(define-public php-phpunit-php-timer
+  (package
+    (name "php-phpunit-php-timer")
+    (version "5.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/php-timer")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0y3wc4ywmpzbjkgnyf8aq2k2kybfmbic2qz46wrqr8d78ah2csf0"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit
+           php-sebastian-global-state))
+    (synopsis "Utility class for timing")
+    (description "This package contains a stand-alone component originally part
+of PHPUnit.  It provides a utility class for timing.")
+    (home-page "https://github.com/sebastianbergmann/php-timer/")
+    (license license:bsd-3)))
+