diff mbox series

[bug#67902,92/95] gnu: Add php-theseer-tokenizer.

Message ID 20231219140934.22783-92-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:58 p.m. UTC
* gnu/packages/php-xyz.scm (php-theseer-tokenizer): New variable.

Change-Id: Ie1a5c3e5161bea664d3999de65e981aa978162b2
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 125b9d0069..20445725b2 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2514,3 +2514,25 @@  (define-public php-doctrine-dbal
     (home-page "https://www.doctrine-project.org/projects/dbal")
     (license license:expat)))
 
+(define-public php-theseer-tokenizer
+  (package
+    (name "php-theseer-tokenizer")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/theseer/tokenizer")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "071bbsxd05rvl41shv7zn86d4f55cd7cjisk9gf0chxk0542sad7"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Convert PHP to XML")
+    (description "This package provides a small library for converting tokenized
+PHP source code into XML and potentially other formats.")
+    (home-page "https://github.com/theseer/tokenizer")
+    (license license:bsd-3)))
+