diff mbox series

[bug#67902,60/95] gnu: Add php-symfony-deprecation-contracts.

Message ID 20231219140934.22783-60-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-deprecation-contracts): New variable.

Change-Id: I4c55b434a870b9eebd29ae4a4a1a6275d99ada98
---
 gnu/packages/php-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 98b65f0cc1..9aa2badffb 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1605,3 +1605,24 @@  (define-public php-symfony-dependency-injection
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-deprecation-contracts
+  (package
+    (name "php-symfony-deprecation-contracts")
+    (version "3.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/deprecation-contracts")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "084i60zif71y07ryh6gb4mvrzp3gpzk342r2p9q8jzw9vggxyhv9"))))
+    (build-system composer-build-system)
+    (synopsis "Trigger deprecation notices in PHP")
+    (description
+     "This package provides a generic function and convention to trigger
+deprecation notices.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+