diff mbox series

[bug#67902,05/95] gnu: Add php-doctrine-common.

Message ID 20231219140934.22783-5-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:56 p.m. UTC
* gnu/packages/php-xyz.scm (php-doctrine-common): New variable.

Change-Id: I261b3f5e5aa32869bb6358064ac1cb049f018d6a
---
 gnu/packages/php-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 62fc999463..484bf03896 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -116,3 +116,30 @@  (define-public php-doctrine-collections
     (home-page "https://www.doctrine-project.org/projects/collections")
     (license license:expat)))
 
+(define-public php-doctrine-common
+  (package
+    (name "php-doctrine-common")
+    (version "3.4.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/doctrine/common")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1hivhghwmqs5jaiicayni35xkpclmdf5r9fb15y5jx7rl5wrsh7f"))))
+    (build-system composer-build-system)
+    (arguments
+     '(#:test-flags '("--bootstrap" "vendor/autoload.php")))
+    (inputs
+     (list php-doctrine-persistence))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "PHP utility library for Doctrine projects")
+    (description
+     "This package provides additional functionality that other Doctrine
+projects depend on such as better reflection support, proxies and much more.")
+    (home-page "https://www.doctrine-project.org/projects/common")
+    (license license:expat)))
+