diff mbox series

[bug#67902,74/95] gnu: Add php-symfony-property-info.

Message ID 20231219140934.22783-74-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-property-info): New variable.

Change-Id: I7e327c1987f35c73a2772bcac33c98c26434e466
---
 gnu/packages/php-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index bbe6f6aa01..81f9f6fcdb 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2053,3 +2053,29 @@  (define-public php-symfony-process
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-property-info
+  (package
+    (name "php-symfony-property-info")
+    (version "6.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/property-info")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ign8wdlgfx15kjc15vddp2mmpbhh7bbmbfkwg1qhyaqknjrifxr"))))
+    (build-system composer-build-system)
+    ;; Native inputs here create a loop that is hard to break.
+    ;; Maybe use a -bootstrap version if testing becomes important.
+    (arguments '(#:tests? #f))
+    (inputs
+     (list php-symfony-string))
+    (synopsis "Get PHP class properties")
+    (description
+     "This package provides utilities to extract information about PHP class'
+properties using metadata of popular sources.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+