diff mbox series

[bug#67902,83/95] gnu: Add php-symfony-string.

Message ID 20231219140934.22783-83-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:58 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-string): New variable.

Change-Id: I2973216fae718c4204d1adc12ed3ca9c7b45974e
---
 gnu/packages/php-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index ddefc1d67e..67c385d3d1 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2259,3 +2259,34 @@  (define-public php-symfony-stopwatch
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-string
+  (package
+    (name "php-symfony-string")
+    (version "6.3.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/string")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0i16bw3b278r8assyly7qrajfln7qg47cxlccq7wmwmypsbihm9l"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-symfony-polyfill-ctype
+           php-symfony-polyfill-intl-grapheme
+           php-symfony-polyfill-intl-normalizer
+           php-symfony-polyfill-mbstring))
+    (native-inputs
+     (list php-phpunit-phpunit
+           php-symfony-error-handler
+           php-symfony-intl
+           php-symfony-translation-contracts))
+    (synopsis "Manipulate strings in PHP")
+    (description
+     "This package provides a PHP object-oriented API to strings and deals with
+bytes, UTF-8 code points and grapheme clusters in a unified way.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+