diff mbox series

[bug#67902,75/95] gnu: Add php-symfony-polyfill-ctype.

Message ID 20231219140934.22783-75-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-symfony-polyfill-ctype): New variable.

Change-Id: I0508970374a7fb378df722ca6ca65a64d0222673
---
 gnu/packages/php-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 81f9f6fcdb..44c5363525 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -2079,3 +2079,23 @@  (define-public php-symfony-property-info
     (home-page "https://symfony.com")
     (license license:expat)))
 
+(define-public php-symfony-polyfill-ctype
+  (package
+    (name "php-symfony-polyfill-ctype")
+    (version "1.28.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/symfony/polyfill-ctype")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1xl4a18gvgc346m8s8pp2lphzlfdvy0jm82bkjrl09ym5qaxk5kv"))))
+    (build-system composer-build-system)
+    (synopsis "Ctype functions for older PHP versions")
+    (description "This component provides @code{ctype_*} functions to users
+who run php versions without the ctype extension.")
+    (home-page "https://symfony.com")
+    (license license:expat)))
+