diff mbox series

[bug#67902,35/95] gnu: Add php-psr-container.

Message ID 20231219140934.22783-35-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-psr-container): New variable.

Change-Id: I85d5f4625f4269d652ccd92ba3e944bb1e3e444b
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index b5c0e6f21c..5c92f18941 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -918,3 +918,25 @@  (define-public php-psr-cache-1
        (sha256
         (base32 "165nhqrqh7q2rrxz86iywv5nkyr0ybxfbnmcxk54bsy6yhkhvg3s"))))))
 
+(define-public php-psr-container
+  (package
+    (name "php-psr-container")
+    (version "2.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/php-fig/container")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "02438i87fa344xm6iv2wsk5pmyjkacdiaa085a4zggw1ivwch8dc"))))
+    (build-system composer-build-system)
+    (synopsis "PHP interfaces relates to PSR-11")
+    (description "This package provides all interfaces related to PSR-11
+(Container Interface).  This is not a Container implementation of its
+own.  It is merely abstractions that describe the components of a Dependency
+Injection Container.")
+    (home-page "https://github.com/php-fig/container")
+    (license license:expat)))
+