diff mbox series

[bug#67902,53/95] gnu: Add php-sebastian-version.

Message ID 20231219140934.22783-53-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-version): New variable.

Change-Id: Ib06b81af002d6b9b28a08ff21764e85b1867907f
---
 gnu/packages/php-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index e1ac626962..e31d112e8b 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1345,3 +1345,23 @@  (define-public php-sebastian-type
     (home-page "https://github.com/sebastianbergmann/type")
     (license license:bsd-3)))
 
+(define-public php-sebastian-version
+  (package
+    (name "php-sebastian-version")
+    (version "3.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/version")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0645hyzf4dbmy3gk7mda3bk1rnxn7qzifawi5ss5mgkqp6x5awvj"))))
+    (build-system composer-build-system)
+    (synopsis "PHP versionning library")
+    (description "This package is a library that helps with managing the version
+number of Git-hosted PHP projects.")
+    (home-page "https://github.com/sebastianbergmann/version")
+    (license license:bsd-3)))
+