diff mbox series

[bug#67902,22/95] gnu: Add php-phpdocumentor-type-resolver.

Message ID 20231219140934.22783-22-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpdocumentor-type-resolver): New variable.

Change-Id: I02aa76ea62067f888b2ca8dfd8c1841d6afba3ab
---
 gnu/packages/php-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 8f72e6ce0b..9c7230d1d3 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -594,3 +594,29 @@  (define-public php-phpdocumentor-reflection-docblock
     (home-page "https://github.com/phpDocumentor/ReflectionDocBlock")
     (license license:expat)))
 
+(define-public php-phpdocumentor-type-resolver
+  (package
+    (name "php-phpdocumentor-type-resolver")
+    (version "1.7.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/phpDocumentor/TypeResolver")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0yird46q6pny0lz0w6kcw1ljmvavcmzhjmaim6jphmf63k40yx6n"))))
+    (build-system composer-build-system)
+    (inputs
+     (list php-doctrine-deprecations
+           php-phpdocumentor-reflection-common
+           php-phpstan-phpdoc-parser))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Resolver of class names, types and structural element names")
+    (description "This package provides a PSR-5 based resolver of class names,
+types and structural element names.")
+    (home-page "http://www.phpdoc.org")
+    (license license:expat)))
+