diff mbox series

[bug#67902,51/95] gnu: Add php-sebastian-resource-operations.

Message ID 20231219140934.22783-51-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-resource-operations): New variable.

Change-Id: Ife7ac40a551a8b6bc704622f70f6a2eb7b4b5856
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 6048264aa7..f22cd7fb98 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1301,3 +1301,25 @@  (define-public php-sebastian-recursion-context
     (home-page "https://github.com/sebastianbergmann/recursion-context")
     (license license:bsd-3)))
 
+(define-public php-sebastian-resource-operations
+  (package
+    (name "php-sebastian-resource-operations")
+    (version "3.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/resource-operations")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1nx8basy2347x9fvr7x4wbz58wh18h8m8qywksc6k47n6srj2qir"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "List built-in PHP functions")
+    (description "This package provides a list of PHP built-in functions that
+operate on resources.")
+    (home-page "https://github.com/sebastianbergmann/resource-operations")
+    (license license:bsd-3)))
+