diff mbox series

[bug#67902,47/95] gnu: Add php-sebastian-lines-of-code.

Message ID 20231219140934.22783-47-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-lines-of-code): New variable.

Change-Id: Ifb0a4e00fab18c53a495d6816d2b0de19389b661
---
 gnu/packages/php-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 2b93d56432..c2bbaa061c 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1187,3 +1187,34 @@  (define-public php-sebastian-global-state
     (home-page "https://github.com/sebastianbergmann/global-state")
     (license license:bsd-3)))
 
+(define-public php-sebastian-lines-of-code
+  (package
+    (name "php-sebastian-lines-of-code")
+    (version "2.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/lines-of-code")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1j5yk9565mh4s46735jlqiz9kxwgxai7g0a0x802alhv9qjpm5p6"))))
+    (build-system composer-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'remove-failing-tests
+            (lambda _
+              (delete-file "tests/unit/LineCountingVisitorTest.php"))))))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (inputs
+     (list php-nikic-php-parser))
+    (synopsis "Count PHP source code lines")
+    (description "This package provides a library for counting the lines of
+code in PHP source code.")
+    (home-page "https://github.com/sebastianbergmann/lines-of-code")
+    (license license:bsd-3)))
+