diff mbox series

[bug#67902,04/95] gnu: Add php-doctrine-collections.

Message ID 20231219140934.22783-4-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:56 p.m. UTC
* gnu/packages/php-xyz.scm (php-doctrine-collections): New variable.

Change-Id: Iacf76a4b9520389943acae985c42c4f268240fdd
---
 gnu/packages/php-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index a4c00e45be..62fc999463 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -89,3 +89,30 @@  (define-public php-cache-tag-interop
     (home-page "https://www.php-cache.com/en/latest/")
     (license license:expat)))
 
+(define-public php-doctrine-collections
+  (package
+    (name "php-doctrine-collections")
+    (version "2.1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/doctrine/collections")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0b384rkxl70bb164373c3y3n72816jkggjm9vg58avb7lqx3dq1i"))))
+    (build-system composer-build-system)
+    (arguments
+     '(#:test-flags '("--bootstrap" "vendor/autoload.php")))
+    (inputs
+     (list php-doctrine-deprecations))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Additional functionality on top of PHP arrays")
+    (description
+     "This package provides a PHP library that adds additional functionality
+on top of arrays.")
+    (home-page "https://www.doctrine-project.org/projects/collections")
+    (license license:expat)))
+