diff mbox series

[bug#67902,10/95] gnu: Add php-doctrine-persistence.

Message ID 20231219140934.22783-10-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:56 p.m. UTC
* gnu/packages/php-xyz.scm (php-doctrine-persistence): New variable.

Change-Id: I9b09ecf84c8334e3967e68f1a86333457ad5a63c
---
 gnu/packages/php-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 464e5f9598..34cd9cc3a3 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -235,3 +235,32 @@  (define-public php-doctrine-lexer
     (home-page "https://www.doctrine-project.org/projects/lexer")
     (license license:expat)))
 
+(define-public php-doctrine-persistence
+  (package
+    (name "php-doctrine-persistence")
+    (version "3.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/doctrine/persistence")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1fynsqafdbajbjirqzhj5gjwkfc7yz45nadgqbhrmh29i0q952bq"))))
+    (build-system composer-build-system)
+    ;; Native inputs here create a loop that is hard to break.
+    ;; Maybe use a -bootstrap version if testing becomes important.
+    (arguments
+     '(#:tests? #f))
+    (inputs
+     (list php-doctrine-event-manager php-psr-cache))
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Shared functionality between the Doctrine object mappers")
+    (description
+     "This package provides a set of shared interfaces and functionality that
+the different Doctrine object mappers share.")
+    (home-page "https://www.doctrine-project.org/projects/persistence")
+    (license license:expat)))
+