diff mbox series

[bug#67902,50/95] gnu: Add php-sebastian-recursion-context.

Message ID 20231219140934.22783-50-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-recursion-context): New variable.

Change-Id: I665c07ffe03ac71fec513dff6cc6c2b8df9ac606
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index e7f057248f..6048264aa7 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -1279,3 +1279,25 @@  (define-public php-sebastian-object-reflector
     (home-page "https://github.com/sebastianbergmann/object-reflector/")
     (license license:bsd-3)))
 
+(define-public php-sebastian-recursion-context
+  (package
+    (name "php-sebastian-recursion-context")
+    (version "4.0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sebastianbergmann/recursion-context")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "02agysiipm41366ww518imz4jz9c3d2886pd3zn1j9m1c2qx7f53"))))
+    (build-system composer-build-system)
+    (native-inputs
+     (list php-phpunit-phpunit))
+    (synopsis "Process PHP variables recursively")
+    (description "This package provides functionality to recursively process
+PHP variables")
+    (home-page "https://github.com/sebastianbergmann/recursion-context")
+    (license license:bsd-3)))
+