diff mbox series

[bug#67902,19/95] gnu: Add php-phar-io-version.

Message ID 20231219140934.22783-19-ngraves@ngraves.fr
State New
Headers show
Series PHP package chain. | expand

Commit Message

Nicolas Graves Dec. 19, 2023, 1:57 p.m. UTC
* gnu/packages/php-xyz.scm (php-phar-io-version): New variable.

Change-Id: Ifa17bbb32419e17b99e06343b83728274f5fa9de
---
 gnu/packages/php-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 5414e34266..87889eae11 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -517,3 +517,23 @@  (define-public php-phar-io-manifest
     (home-page "https://phar.io")
     (license license:bsd-3)))
 
+(define-public php-phar-io-version
+  (package
+    (name "php-phar-io-version")
+    (version "3.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/phar-io/version")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0cl43mn5vxm8m364b6sjmklva201vx0kpm3zf8aq021l3xllh5fz"))))
+    (build-system composer-build-system)
+    (synopsis "Library for handling version information and constraints")
+    (description "This package contains a library for handling version information
+and constraints.")
+    (home-page "https://phar.io")
+    (license license:bsd-3)))
+