diff mbox series

[bug#69257,112/228] gnu: Place rust-const-fn-assert-0.1 in alphabetical order.

Message ID fb088fcafe063882b11c854fdcc6f7c7cf2c578d.1708288186.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:08 p.m. UTC
gnu/packages/crates-io.scm (rust-const-fn-assert-0.1): Move variable.

Change-Id: Id65592fce294a76d3a7f3a3cea9b84da46bbb8d0
---
 gnu/packages/crates-io.scm | 32 ++++++++++++++++----------------
 1 file changed, 16 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1fd107c77e..614cccdfc5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12811,22 +12811,6 @@  (define-public rust-const-cstr-0.3
 literals.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-const-fn-assert-0.1
-  (package
-    (name "rust-const-fn-assert")
-    (version "0.1.2")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "const_fn_assert" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32 "1451yxndri5zj95lyjzckj7m3qlpyj8ibp3pb8bbbxrl7zr19mi7"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/powlpy/const_fn_assert")
-    (synopsis "Assertions for const functions")
-    (description "Assertions for const functions.")
-    (license license:expat)))
-
 ;; This package requires features which are unavailable
 ;; on the stable releases of Rust.
 (define-public rust-compiler-builtins-0.1
@@ -13687,6 +13671,22 @@  (define-public rust-const-fn-0.4
 const functions with conditional compilations.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-const-fn-assert-0.1
+  (package
+    (name "rust-const-fn-assert")
+    (version "0.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "const_fn_assert" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32 "1451yxndri5zj95lyjzckj7m3qlpyj8ibp3pb8bbbxrl7zr19mi7"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/powlpy/const_fn_assert")
+    (synopsis "Assertions for const functions")
+    (description "Assertions for const functions.")
+    (license license:expat)))
+
 (define-public rust-const-format-0.2
   (package
     (name "rust-const-format")