diff mbox series

[bug#69257,192/228] gnu: Add rust-matrix-sdk-base-0.7.

Message ID 78474b68cf8561c550f3f6e8b930d2cd5678a0db.1708288189.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:09 p.m. UTC
* gnu/packages/crates-io.scm (rust-matrix-sdk-base-0.7): Add variable.

Change-Id: I09bf97dcb3b7d40f43d007bb178dfd9548807622
---
 gnu/packages/crates-io.scm | 51 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b775d9a8b8..e7bc84a9f0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37622,6 +37622,57 @@  (define-public rust-matrix-pickle-derive-0.1
      "This package provides Derive support for @code{matrix-pickle}.")
     (license license:expat)))
 
+(define-public rust-matrix-sdk-base-0.7
+  (package
+    (name "rust-matrix-sdk-base")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "matrix-sdk-base" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "11qcrwqhv5w2sbcya6sc4cx00xj1lsy6rx1hs7qr8sl2s1a1k280"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-as-variant" ,rust-as-variant-1)
+        ("rust-assert-matches" ,rust-assert-matches-1)
+        ("rust-assert-matches2" ,rust-assert-matches2-0.1)
+        ("rust-async-trait" ,rust-async-trait-0.1)
+        ("rust-bitflags" ,rust-bitflags-2)
+        ("rust-eyeball" ,rust-eyeball-0.8)
+        ("rust-eyeball-im" ,rust-eyeball-im-0.4)
+        ("rust-futures-util" ,rust-futures-util-0.3)
+        ("rust-http" ,rust-http-0.2)
+        ("rust-matrix-sdk-common" ,rust-matrix-sdk-common-0.7)
+        ("rust-matrix-sdk-crypto" ,rust-matrix-sdk-crypto-0.7)
+        ("rust-matrix-sdk-store-encryption" ,rust-matrix-sdk-store-encryption-0.7)
+        ("rust-matrix-sdk-test" ,rust-matrix-sdk-test-0.7)
+        ("rust-once-cell" ,rust-once-cell-1)
+        ("rust-ruma" ,rust-ruma-0.9)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-thiserror" ,rust-thiserror-1)
+        ("rust-tokio" ,rust-tokio-1)
+        ("rust-tracing" ,rust-tracing-0.1))
+       #:cargo-development-inputs
+       (("rust-assert-matches" ,rust-assert-matches-1)
+        ("rust-assert-matches2" ,rust-assert-matches2-0.1)
+        ("rust-assign" ,rust-assign-1)
+        ("rust-futures-executor" ,rust-futures-executor-0.3)
+        ("rust-http" ,rust-http-0.2)
+        ("rust-matrix-sdk-test" ,rust-matrix-sdk-test-0.7)
+        ("rust-stream-assert" ,rust-stream-assert-0.1)
+        ("rust-tokio" ,rust-tokio-1)
+        ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3))))
+    (home-page "https://github.com/matrix-org/matrix-rust-sdk")
+    (synopsis "Base component to build a Matrix client library")
+    (description
+      "This package provides the base component to build a Matrix client
+library.")
+    (license license:asl2.0)))
+
 (define-public rust-matrix-sdk-common-0.7
   (package
     (name "rust-matrix-sdk-common")