diff mbox series

[bug#69257,074/228] gnu: Add rust-pulldown-cmark-to-cmark-10.

Message ID 65edc8d271a82e6d544e560c1ad86fedd1030d84.1708288184.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:03 p.m. UTC
* gnu/packages/crates-io.scm (rust-pulldown-cmark-to-cmark-10): Add
variable.
(rust-pulldown-cmark-to-cmark-7): Inherit
rust-pulldown-cmark-to-cmark-10.

Change-Id: I4c9e072c975ca6d91524fc66de8ceea708515e62
---
 gnu/packages/crates-io.scm | 36 +++++++++++++++++++++++++++---------
 1 file changed, 27 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b46be68b7c..9b98774bd1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -51348,8 +51348,34 @@  (define-public rust-pulldown-cmark-0.1
        (("rust-bitflags" ,rust-bitflags-0.9)
         ("rust-getopts" ,rust-getopts-0.2))))))
 
+(define-public rust-pulldown-cmark-to-cmark-10
+  (package
+    (name "rust-pulldown-cmark-to-cmark")
+    (version "10.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pulldown-cmark-to-cmark" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0gc366cmd5jxal9m95l17rvqsm4dn62lywc8v5gwq8vcjvhyd501"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-pulldown-cmark" ,rust-pulldown-cmark-0.9))
+       #:cargo-development-inputs
+       (("rust-indoc" ,rust-indoc-1)
+        ("rust-pretty-assertions" ,rust-pretty-assertions-0.7))))
+    (home-page "https://github.com/Byron/pulldown-cmark-to-cmark")
+    (synopsis
+     "Convert pulldown-cmark Events back into source strings")
+    (description
+     "This package provides a convert pulldown-cmark Events back to the
+string they were parsed from.")
+    (license license:asl2.0)))
+
 (define-public rust-pulldown-cmark-to-cmark-7
   (package
+    (inherit rust-pulldown-cmark-to-cmark-10)
     (name "rust-pulldown-cmark-to-cmark")
     (version "7.1.1")
     (source
@@ -51369,15 +51395,7 @@  (define-public rust-pulldown-cmark-to-cmark-7
        #:cargo-development-inputs
        (("rust-indoc" ,rust-indoc-1)
         ("rust-pretty-assertions"
-         ,rust-pretty-assertions-0.7))))
-    (home-page
-     "https://github.com/Byron/pulldown-cmark-to-cmark")
-    (synopsis
-     "Convert pulldown-cmark Events back to the string they were parsed from")
-    (description
-     "This package provides a convert pulldown-cmark Events back to the string
-they were parsed from")
-    (license license:asl2.0)))
+         ,rust-pretty-assertions-0.7))))))
 
 (define-public rust-pulse-0.5
   (package