diff mbox series

[bug#69257,137/228] gnu: Place rust-jwalk-0.8 in alphabetical order.

Message ID 45e30a6cb61b975dc9e2a2d97a8cb28abbbb2881.1708288187.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:08 p.m. UTC
gnu/packages/crates-io.scm (rust-jwalk-0.8): Move variable.

Change-Id: Iefebcd823a9a9cf69ffec0b36a9429bce5c8de75
---
 gnu/packages/crates-io.scm | 62 +++++++++++++++++++-------------------
 1 file changed, 31 insertions(+), 31 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4410e821bd..30eb556d20 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29363,37 +29363,6 @@  (define-public rust-hts-sys-2
     (description "This library provides Rust bindings to HTSlib.")
     (license license:expat)))
 
-(define-public rust-jwalk-0.8
-  (package
-    (name "rust-jwalk")
-    (version "0.8.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "jwalk" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0miw0074ch6p89dbvrlnz9wp13rh7542cf1ak8bx4v1mcrsq8d97"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-crossbeam" ,rust-crossbeam-0.8)
-        ("rust-rayon" ,rust-rayon-1))
-       #:cargo-development-inputs
-       (("rust-criterion" ,rust-criterion-0.4)
-        ("rust-fs-extra" ,rust-fs-extra-1)
-        ("rust-ignore" ,rust-ignore-0.4)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-num-cpus" ,rust-num-cpus-1)
-        ("rust-tempfile" ,rust-tempfile-3)
-        ("rust-walkdir" ,rust-walkdir-2))))
-    (home-page "https://github.com/byron/jwalk")
-    (synopsis
-     "Filesystem walk performed in parallel with streamed and sorted results")
-    (description
-     "Filesystem walk performed in parallel with streamed and sorted results.")
-    (license license:expat)))
-
 (define-public rust-human-format-1
   (package
     (name "rust-human-format")
@@ -32952,6 +32921,37 @@  (define-public rust-juniper-0.14
 debugging.")
     (license license:bsd-2)))
 
+(define-public rust-jwalk-0.8
+  (package
+    (name "rust-jwalk")
+    (version "0.8.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "jwalk" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0miw0074ch6p89dbvrlnz9wp13rh7542cf1ak8bx4v1mcrsq8d97"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-crossbeam" ,rust-crossbeam-0.8)
+        ("rust-rayon" ,rust-rayon-1))
+       #:cargo-development-inputs
+       (("rust-criterion" ,rust-criterion-0.4)
+        ("rust-fs-extra" ,rust-fs-extra-1)
+        ("rust-ignore" ,rust-ignore-0.4)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-num-cpus" ,rust-num-cpus-1)
+        ("rust-tempfile" ,rust-tempfile-3)
+        ("rust-walkdir" ,rust-walkdir-2))))
+    (home-page "https://github.com/byron/jwalk")
+    (synopsis
+     "Filesystem walk performed in parallel with streamed and sorted results")
+    (description
+     "Filesystem walk performed in parallel with streamed and sorted results.")
+    (license license:expat)))
+
 (define-public rust-keccak-0.1
   (package
     (name "rust-keccak")