diff mbox series

[bug#69257,084/228] gnu: Place rust-paw-attributes-1 in alphabetical order.

Message ID 4feafcb074022dbb900e34305341e43dde6aefd0.1708288185.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:03 p.m. UTC
gnu/packages/crates-io.scm (rust-paw-attributes-1): Move variable.

Change-Id: Icb49b996e36f8ba04d43ed3ed88407b42151b253
---
 gnu/packages/crates-io.scm | 46 +++++++++++++++++++-------------------
 1 file changed, 23 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 580ecb100a..ad31493234 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46572,6 +46572,29 @@  (define-public rust-pathdiff-0.2
 path.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-paw-attributes-1
+  (package
+    (name "rust-paw-attributes")
+    (version "1.0.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "paw-attributes" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "0fda1v7y5pfmg8d2v7m0pyvif6c44qjz914jjn718pdyclrmhd8g"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-proc-macro2" ,rust-proc-macro2-1)
+         ("rust-quote" ,rust-quote-1)
+         ("rust-syn" ,rust-syn-1))))
+    (home-page "https://github.com/rust-cli/paw")
+    (synopsis "Proc Macro attributes for the Paw crate")
+    (description "This package provides Proc Macro attributes for the Paw
+crate.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-paw-raw-1
   (package
     (name "rust-paw-raw")
@@ -63487,29 +63510,6 @@  (define-public rust-paw-1
     (description "This package provides a CLI argument parser.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-paw-attributes-1
-  (package
-    (name "rust-paw-attributes")
-    (version "1.0.2")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "paw-attributes" version))
-        (file-name (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32 "0fda1v7y5pfmg8d2v7m0pyvif6c44qjz914jjn718pdyclrmhd8g"))))
-    (build-system cargo-build-system)
-    (arguments
-      `(#:cargo-inputs
-        (("rust-proc-macro2" ,rust-proc-macro2-1)
-         ("rust-quote" ,rust-quote-1)
-         ("rust-syn" ,rust-syn-1))))
-    (home-page "https://github.com/rust-cli/paw")
-    (synopsis "Proc Macro attributes for the Paw crate")
-    (description "This package provides Proc Macro attributes for the Paw
-crate.")
-    (license (list license:expat license:asl2.0))))
-
 ;; TODO: Unbundle sleef.
 (define-public rust-sleef-sys-0.1
   (package