diff mbox series

[bug#69257,060/228] gnu: Add rust-sync-wrapper-0.1.

Message ID ef758a396b163f4434e570a444d467439747505e.1708288184.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:02 p.m. UTC
* gnu/packages/crates-io.scm (rust-sync-wrapper-0.1): Add variable.

Change-Id: I1d37a32a26b4afebd99802e425e4a1b60184b5cf
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6a2070fc57..2743293e42 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -67643,6 +67643,31 @@  (define-public rust-syn-test-suite-0.0.0
     (description "Test suite of the syn crate.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-sync-wrapper-0.1
+  (package
+    (name "rust-sync-wrapper")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "sync_wrapper" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0q01lyj0gr9a93n10nxsn8lwbzq97jqd6b768x17c8f7v7gccir0"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-futures-core" ,rust-futures-core-0.3))
+       #:cargo-development-inputs
+       (("rust-futures" ,rust-futures-0.3)
+        ("rust-pin-project-lite" ,rust-pin-project-lite-0.2))))
+    (home-page "https://docs.rs/sync_wrapper")
+    (synopsis
+     "Enlist the compiler's help in proving the absence of concurrency")
+    (description
+     "This package provides a tool for enlisting the compiler's help in
+proving the absence of concurrency.")
+    (license license:asl2.0)))
+
 (define-public rust-synchronoise-1
   (package
     (name "rust-synchronoise")