diff mbox series

[bug#69257,115/228] gnu: Add rust-warp-0.3.

Message ID 2431e28d0ab2177866ff511536d0ce9edbbe0092.1708288186.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:08 p.m. UTC
* gnu/packages/crates-web.scm (rust-warp-0.3): Add variable.
(rust-warp-0.2): Inherit from rust-warp-0.3.

Change-Id: I5f3683ac83fd4d607b3095285f263eb889ece61e
---
 gnu/packages/crates-web.scm | 53 ++++++++++++++++++++++++++++++++-----
 1 file changed, 47 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 1bc8f504ab..afd85d4d1e 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -5750,8 +5750,54 @@  (define-public rust-typed-headers-0.1
         ("rust-http" ,rust-http-0.1)
         ("rust-mime" ,rust-mime-0.3))))))
 
+(define-public rust-warp-0.3
+  (package
+    (name "rust-warp")
+    (version "0.3.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "warp" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0sfimrpxkyka1mavfhg5wa4x977qs8vyxa510c627w9zw0i2xsf1"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-async-compression" ,rust-async-compression-0.3)
+        ("rust-bytes" ,rust-bytes-1)
+        ("rust-futures-channel" ,rust-futures-channel-0.3)
+        ("rust-futures-util" ,rust-futures-util-0.3)
+        ("rust-headers" ,rust-headers-0.3)
+        ("rust-http" ,rust-http-0.2)
+        ("rust-hyper" ,rust-hyper-0.14)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-mime" ,rust-mime-0.3)
+        ("rust-mime-guess" ,rust-mime-guess-2)
+        ("rust-multer" ,rust-multer-2)
+        ("rust-percent-encoding" ,rust-percent-encoding-2)
+        ("rust-pin-project" ,rust-pin-project-1)
+        ("rust-rustls-pemfile" ,rust-rustls-pemfile-1)
+        ("rust-scoped-tls" ,rust-scoped-tls-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-serde-urlencoded" ,rust-serde-urlencoded-0.7)
+        ("rust-tokio" ,rust-tokio-1)
+        ("rust-tokio-rustls" ,rust-tokio-rustls-0.24)
+        ("rust-tokio-stream" ,rust-tokio-stream-0.1)
+        ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.20)
+        ("rust-tokio-util" ,rust-tokio-util-0.7)
+        ("rust-tower-service" ,rust-tower-service-0.3)
+        ("rust-tracing" ,rust-tracing-0.1))))
+    (home-page "https://github.com/seanmonstar/warp")
+    (synopsis "Serve the web at warp speeds")
+    (description "Warp is a composable, web server framework.")
+    (license license:expat)))
+
 (define-public rust-warp-0.2
   (package
+    (inherit rust-warp-0.3)
     (name "rust-warp")
     (version "0.2.5")
     (source
@@ -5761,7 +5807,6 @@  (define-public rust-warp-0.2
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "01wl8kv5hh1dd7gcwdrmn9xfs7jjsh9yc8xa06ph8yf9akgyc6zl"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
@@ -5786,11 +5831,7 @@  (define-public rust-warp-0.2
         ("rust-tower-service" ,rust-tower-service-0.3)
         ("rust-tracing" ,rust-tracing-0.1)
         ("rust-tracing-futures" ,rust-tracing-futures-0.2)
-        ("rust-urlencoding" ,rust-urlencoding-1))))
-    (home-page "https://github.com/seanmonstar/warp")
-    (synopsis "Composable web server framework")
-    (description "Warp is a composable, web server framework.")
-    (license license:expat)))
+        ("rust-urlencoding" ,rust-urlencoding-1))))))
 
 (define-public rust-web-view-0.7
   (package