diff mbox series

[bug#69257,148/228] gnu: Add rust-ruma-events-0.27.

Message ID e588d6ecbe4d19c43c4c298b791836774e2c56eb.1708288187.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:08 p.m. UTC
* gnu/packages/crates-io.scm (rust-ruma-events-0.27): Add variable.

Change-Id: I87a2b6ab0c6bcce05e6f60eabde90429a42d3fdb
---
 gnu/packages/crates-io.scm | 46 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 83a3d12d01..c7dededf6e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -57923,6 +57923,52 @@  (define-public rust-ruma-common-0.12
 crates.")
     (license license:expat)))
 
+(define-public rust-ruma-events-0.27
+  (package
+    (name "rust-ruma-events")
+    (version "0.27.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ruma-events" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1wg3smmqxxwl03j5hkk707fdlxng7n5vl50wg85v77ss1rvm42nj"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-as-variant" ,rust-as-variant-1)
+        ("rust-criterion" ,rust-criterion-0.5)
+        ("rust-indexmap" ,rust-indexmap-2)
+        ("rust-js-int" ,rust-js-int-0.2)
+        ("rust-js-option" ,rust-js-option-0.1)
+        ("rust-percent-encoding" ,rust-percent-encoding-2)
+        ("rust-pulldown-cmark" ,rust-pulldown-cmark-0.9)
+        ("rust-regex" ,rust-regex-1)
+        ("rust-ruma-common" ,rust-ruma-common-0.12)
+        ("rust-ruma-html" ,rust-ruma-html-0.1)
+        ("rust-ruma-identifiers-validation"
+         ,rust-ruma-identifiers-validation-0.9)
+        ("rust-ruma-macros" ,rust-ruma-macros-0.12)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-thiserror" ,rust-thiserror-1)
+        ("rust-tracing" ,rust-tracing-0.1)
+        ("rust-url" ,rust-url-2)
+        ("rust-wildmatch" ,rust-wildmatch-2))
+       #:cargo-development-inputs
+       (("rust-assert-matches2" ,rust-assert-matches2-0.1)
+        ("rust-assign" ,rust-assign-1)
+        ("rust-http" ,rust-http-0.2)
+        ("rust-maplit" ,rust-maplit-1)
+        ("rust-trybuild" ,rust-trybuild-1))))
+    (home-page "https://ruma.io/")
+    (synopsis "Serializable types for events in the Matrix specification")
+    (description
+     "This package provides serializable types for the events in the
+Matrix specification.")
+    (license license:expat)))
+
 (define-public rust-ruma-html-0.1
   (package
     (name "rust-ruma-html")