diff mbox series

[bug#69257,023/228] gnu: Place rust-rt-format-0.3 in alphabetical order.

Message ID 8f07ab1afc6dfbd12764c182c5235732978af239.1708288183.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:02 p.m. UTC
gnu/packages/crates-io.scm (rust-rt-format-0.3): Move variable.

Change-Id: I71364774e17b776c43b696791a98c01e62655c10
---
 gnu/packages/crates-io.scm | 52 +++++++++++++++++++-------------------
 1 file changed, 26 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3bd7747095..dbc3a35ab9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16235,32 +16235,6 @@  (define-public rust-rtoolbox-0.0.1
 backwards compatibility guarantees.")
     (license license:asl2.0)))
 
-(define-public rust-rt-format-0.3
-  (package
-    (name "rust-rt-format")
-    (version "0.3.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "rt-format" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1qjjwh9ny95xck1kp99gi6hfm9glrx54jx8npnj6yccxc7p7q225"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-regex" ,rust-regex-1))))
-    (home-page "https://github.com/vstojkovic/rt-format")
-    (synopsis "Runtime equivalent of the Rust format! macro")
-    (description "This package provides a runtime equivalent of the Rust
-format! macro. It allows formatting strings like the format! macro, with the
-formatting string and the arguments provided at runtime.  This crate supports
-all the formatting features of the format! macro, except for the fill
-character.")
-    (license license:asl2.0)))
-
 (define-public rust-cssparser-0.29
   (package
     (name "rust-cssparser")
@@ -56204,6 +56178,32 @@  (define-public rust-rstest-test-0.9
         ("rust-rstest" ,rust-rstest-0.15)
         ("rust-temp-testdir" ,rust-temp-testdir-0.2))))))
 
+(define-public rust-rt-format-0.3
+  (package
+    (name "rust-rt-format")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rt-format" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1qjjwh9ny95xck1kp99gi6hfm9glrx54jx8npnj6yccxc7p7q225"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-regex" ,rust-regex-1))))
+    (home-page "https://github.com/vstojkovic/rt-format")
+    (synopsis "Runtime equivalent of the Rust format! macro")
+    (description "This package provides a runtime equivalent of the Rust
+format! macro. It allows formatting strings like the format! macro, with the
+formatting string and the arguments provided at runtime.  This crate supports
+all the formatting features of the format! macro, except for the fill
+character.")
+    (license license:asl2.0)))
+
 (define-public rust-rtnetlink-0.14
   (package
     (name "rust-rtnetlink")