diff mbox series

[bug#69257,129/228] gnu: Place rust-konst-macro-rules-0.2 in alphabetical order.

Message ID 011a28fb7ff325c7156cc7d09ed83f3a0568a14b.1708288187.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:08 p.m. UTC
gnu/packages/crates-io.scm (rust-konst-macro-rules-0.2): Move variable.

Change-Id: Id00195abf89f6df4b29693d548b9117b95428881
---
 gnu/packages/crates-io.scm | 34 +++++++++++++++++-----------------
 1 file changed, 17 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index eacdb9a35f..f2910219ca 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29392,23 +29392,6 @@  (define-public rust-konst-0.2
      "Const equivalents of std functions, compile-time comparison, and parsing.")
     (license license:zlib)))
 
-(define-public rust-konst-macro-rules-0.2
-  (package
-    (name "rust-konst-macro-rules")
-    (version "0.2.19")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "konst_macro_rules" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0dswja0dqcww4x3fwjnirc0azv2n6cazn8yv0kddksd8awzkz4x4"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/rodrimati1992/konst/")
-    (synopsis "Implementation detail of the konst crate")
-    (description "Implementation detail of the konst crate.")
-    (license license:zlib)))
-
 (define-public rust-human-format-1
   (package
     (name "rust-human-format")
@@ -33041,6 +33024,23 @@  (define-public rust-khronos-api-3
      "The Khronos XML API Registry, exposed as byte string constants.")
     (license license:asl2.0)))
 
+(define-public rust-konst-macro-rules-0.2
+  (package
+    (name "rust-konst-macro-rules")
+    (version "0.2.19")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "konst_macro_rules" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0dswja0dqcww4x3fwjnirc0azv2n6cazn8yv0kddksd8awzkz4x4"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/rodrimati1992/konst/")
+    (synopsis "Implementation detail of the konst crate")
+    (description "Implementation detail of the konst crate.")
+    (license license:zlib)))
+
 (define-public rust-konst-proc-macros-0.3
   (package
     (name "rust-konst-proc-macros")