diff mbox series

[bug#69257,057/228] gnu: Add rust-hyper-1.

Message ID 92be2386b8138ab3e9d380a2f0d3e033692c6491.1708288184.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:02 p.m. UTC
* gnu/packages/crates-web.scm (rust-hyper-1): Add variable.
(rust-hyper-0.14): Inherit rust-hyper-1.

Change-Id: I4a803247155cae29dab9e9d4bcf915196d8ee31f
---
 gnu/packages/crates-web.scm | 50 +++++++++++++++++++++++++++++++++----
 1 file changed, 45 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index fe2693b208..a35f0b8c25 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2559,8 +2559,52 @@  (define-public rust-httpdate-1
      "This crates parses and formats HTTP datetime strings.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-hyper-1
+  (package
+    (name "rust-hyper")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hyper" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0xgv4bjm78w50wp2rcxc4dg69nw6blx6hyyqkqd7p4gwf4waanpv"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bytes" ,rust-bytes-1)
+                       ("rust-futures-channel" ,rust-futures-channel-0.3)
+                       ("rust-futures-util" ,rust-futures-util-0.3)
+                       ("rust-h2" ,rust-h2-0.4)
+                       ("rust-http" ,rust-http-1)
+                       ("rust-http-body" ,rust-http-body-1)
+                       ("rust-http-body-util" ,rust-http-body-util-0.1)
+                       ("rust-httparse" ,rust-httparse-1)
+                       ("rust-httpdate" ,rust-httpdate-1)
+                       ("rust-itoa" ,rust-itoa-1)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-pin-project-lite" ,rust-pin-project-lite-0.2)
+                       ("rust-tokio" ,rust-tokio-1)
+                       ("rust-tracing" ,rust-tracing-0.1)
+                       ("rust-want" ,rust-want-0.3))
+       #:cargo-development-inputs
+       (("rust-form-urlencoded" ,rust-form-urlencoded-1)
+        ("rust-http-body-util" ,rust-http-body-util-0.1)
+        ("rust-pretty-env-logger" ,rust-pretty-env-logger-0.5)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-spmc" ,rust-spmc-0.3)
+        ("rust-tokio" ,rust-tokio-1)
+        ("rust-tokio-test" ,rust-tokio-test-0.4)
+        ("rust-tokio-util" ,rust-tokio-util-0.7))))
+    (home-page "https://hyper.rs")
+    (synopsis "Fast and correct HTTP library")
+    (description "This package provides a fast and correct HTTP library.")
+    (license license:expat)))
+
 (define-public rust-hyper-0.14
   (package
+    (inherit rust-hyper-1)
     (name "rust-hyper")
     (version "0.14.27")
     (source
@@ -2603,11 +2647,7 @@  (define-public rust-hyper-0.14
         ("rust-tokio-test" ,rust-tokio-test-0.4)
         ("rust-tokio-util" ,rust-tokio-util-0.7)
         ("rust-tower" ,rust-tower-0.4)
-        ("rust-url" ,rust-url-2))))
-    (home-page "https://hyper.rs")
-    (synopsis "Fast and correct HTTP library")
-    (description "This package provides a fast and correct HTTP library.")
-    (license license:expat)))
+        ("rust-url" ,rust-url-2))))))
 
 (define-public rust-hyper-0.13
   (package