diff mbox series

[bug#69257,015/228] gnu: Place rust-twox-hash-1 in alphabetical order.

Message ID 7ca953fccaab97da314bc5614333bc050c011917.1708288182.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:02 p.m. UTC
gnu/packages/crates-io.scm (rust-twox-hash-1): Move variable.

Change-Id: Icb0d2a5f834af969f235aaef48b2b848277801b3
---
 gnu/packages/crates-io.scm | 58 +++++++++++++++++++-------------------
 1 file changed, 29 insertions(+), 29 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 09113a8fc1..15ca3e7645 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37654,35 +37654,6 @@  (define-public rust-merlin-2
 non-interactive protocols can be implemented as if they were interactive.")
     (license license:expat)))
 
-(define-public rust-twox-hash-1
-  (package
-    (name "rust-twox-hash")
-    (version "1.6.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "twox-hash" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0xgn72j36a270l5ls1jk88n7bmq2dhlfkbhdh5554hbagjsydzlp"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-cfg-if" ,rust-cfg-if-0.1)
-        ("rust-digest" ,rust-digest-0.8)
-        ("rust-digest" ,rust-digest-0.9)
-        ("rust-digest" ,rust-digest-0.10)
-        ("rust-rand" ,rust-rand-0.8)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-static-assertions" ,rust-static-assertions-1))
-       #:cargo-development-inputs
-       (("rust-serde-json" ,rust-serde-json-1))))
-    (home-page "https://github.com/shepmaster/twox-hash")
-    (synopsis "Rust implementation of the XXHash and XXH3 algorithms")
-    (description "This package provides a Rust implementation of the XXHash
-and XXH3 algorithms.")
-    (license license:expat)))
-
 (define-public rust-metrics-macros-0.2
   (package
     (name "rust-metrics-macros")
@@ -74532,6 +74503,35 @@  (define-public rust-twoway-0.1
         (base32
 		"1lbf64snscr3vz71jbl6i2c8zr2ndsiqbk6316z39fj1a8mipcar"))))))
 
+(define-public rust-twox-hash-1
+  (package
+    (name "rust-twox-hash")
+    (version "1.6.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "twox-hash" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0xgn72j36a270l5ls1jk88n7bmq2dhlfkbhdh5554hbagjsydzlp"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if-0.1)
+        ("rust-digest" ,rust-digest-0.8)
+        ("rust-digest" ,rust-digest-0.9)
+        ("rust-digest" ,rust-digest-0.10)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-static-assertions" ,rust-static-assertions-1))
+       #:cargo-development-inputs
+       (("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/shepmaster/twox-hash")
+    (synopsis "Rust implementation of the XXHash and XXH3 algorithms")
+    (description "This package provides a Rust implementation of the XXHash
+and XXH3 algorithms.")
+    (license license:expat)))
+
 (define-public rust-typeable-0.1
   (package
     (name "rust-typeable")