diff mbox series

[bug#69257,025/228] gnu: Place rust-roxmltree-0.14 in alphabetical order.

Message ID 06bcad65c7278ecf50d60ff292e2fa1593f48b31.1708288183.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:02 p.m. UTC
gnu/packages/crates-io.scm (rust-roxmltree-0.14): Move variable.

Change-Id: I71364774e17b776c43b696791a98c01e62655c10
---
 gnu/packages/crates-io.scm | 44 +++++++++++++++++++-------------------
 1 file changed, 22 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a1abbc2b04..71453a775e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16188,28 +16188,6 @@  (define-public rust-rodio-0.15
 many formats including AAC, FLAC, MP3, MP4 and WAV.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-roxmltree-0.14
-  (package
-    (name "rust-roxmltree")
-    (version "0.14.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "roxmltree" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "010mahzyarkzb7kaawgga1a9y46nsp209yh2i4g4pq98bg8afn5z"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-xmlparser" ,rust-xmlparser-0.13))))
-    (home-page "https://github.com/RazrFalcon/roxmltree")
-    (synopsis "Represent an XML as a read-only tree")
-    (description
-     "@code{roxmltree} represents an XML 1.0 document as a read-only tree.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-cssparser-0.29
   (package
     (name "rust-cssparser")
@@ -55391,6 +55369,28 @@  (define-public rust-rowan-0.15
      "This package provides a library for generic lossless syntax trees.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-roxmltree-0.14
+  (package
+    (name "rust-roxmltree")
+    (version "0.14.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "roxmltree" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "010mahzyarkzb7kaawgga1a9y46nsp209yh2i4g4pq98bg8afn5z"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-xmlparser" ,rust-xmlparser-0.13))))
+    (home-page "https://github.com/RazrFalcon/roxmltree")
+    (synopsis "Represent an XML as a read-only tree")
+    (description
+     "@code{roxmltree} represents an XML 1.0 document as a read-only tree.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-rpassword-7
   (package
     (name "rust-rpassword")