diff mbox series

[bug#69257,079/228] gnu: Add rust-ordered-float-4.

Message ID 2a78da4970b896d8551f67d7acebc009084ec0e3.1708288185.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:03 p.m. UTC
* gnu/packages/crates-web.scm (rust-ordered-float-4): Add variable.
(rust-ordered-float-3): Inherit rust-ordered-float-4.

Change-Id: I0df7deda3c1b17424f15a42acc1679a1c33f672a
---
 gnu/packages/crates-io.scm | 36 ++++++++++++++++++++++++++----------
 1 file changed, 26 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9813cc3f4b..002846456f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -44461,20 +44461,21 @@  (define-public rust-ord-subset-3
 PartialOrd types, like floats.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-ordered-float-3
+(define-public rust-ordered-float-4
   (package
     (name "rust-ordered-float")
-    (version "3.4.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "ordered-float" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1gr31ksgbqariv6hz3s5bc15a5vh4k65dyn8m7j59lhnji0b2knq"))))
+    (version "4.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ordered-float" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0kjqcvvbcsibbx3hnj7ag06bd9gv2zfi5ja6rgyh2kbxbh3zfvd7"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs (("rust-arbitrary" ,rust-arbitrary-1)
+                       ("rust-borsh" ,rust-borsh-1)
                        ("rust-bytemuck" ,rust-bytemuck-1)
                        ("rust-num-traits" ,rust-num-traits-0.2)
                        ("rust-proptest" ,rust-proptest-1)
@@ -44482,13 +44483,28 @@  (define-public rust-ordered-float-3
                        ("rust-rkyv" ,rust-rkyv-0.7)
                        ("rust-schemars" ,rust-schemars-0.8)
                        ("rust-serde" ,rust-serde-1)
-                       ("rust-speedy" ,rust-speedy-0.8))))
+                       ("rust-speedy" ,rust-speedy-0.8))
+       #:cargo-development-inputs (("rust-serde-test" ,rust-serde-test-1))))
     (home-page "https://github.com/reem/rust-ordered-float")
     (synopsis "Wrappers for total ordering on floats")
     (description
      "This package provides wrappers for total ordering on floats in Rust.")
     (license license:expat)))
 
+(define-public rust-ordered-float-3
+  (package
+    ;; Does not depend on rust-borsh-1 and rust-serde-test-1.
+    (inherit rust-ordered-float-4)
+    (name "rust-ordered-float")
+    (version "3.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "ordered-float" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1gr31ksgbqariv6hz3s5bc15a5vh4k65dyn8m7j59lhnji0b2knq"))))))
+
 (define-public rust-ordered-float-2
   (package
     (inherit rust-ordered-float-3)