diff mbox series

[bug#69257,134/228] gnu: Add rust-konst-kernel-0.3.

Message ID a1523defce284527048800ce36df4ffd9fa88631.1708288187.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:08 p.m. UTC
* gnu/packages/crates-io.scm (rust-konst-kernel-0.3): Add variable.

Change-Id: I5fbe2abfef2ea1ea26883a45cd2f3912a888d4b5
---
 gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 22fcbaf98d..706b48e8cc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33070,6 +33070,28 @@  (define-public rust-khronos-api-3
      "The Khronos XML API Registry, exposed as byte string constants.")
     (license license:asl2.0)))
 
+(define-public rust-konst-kernel-0.3
+  (package
+    (name "rust-konst-kernel")
+    (version "0.3.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "konst_kernel" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "140pxwbaqzchks1a962d8m99dx7b5glbhffgh6520vkb6y6fmins"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-typewit" ,rust-typewit-1))
+       #:cargo-development-inputs (("rust-arrayvec" ,rust-arrayvec-0.7))))
+    (home-page "https://github.com/rodrimati1992/konst/")
+    (synopsis "Foundational functionality shared by konst and const_panic")
+    (description
+     "This package provides the foundational const functionality shared
+between konst and const_panic.")
+    (license license:zlib)))
+
 (define-public rust-konst-macro-rules-0.2
   (package
     (name "rust-konst-macro-rules")