diff mbox series

[bug#69257,214/228] gnu: Add rust-oneshot-uniffi-0.1.

Message ID 4193f19e142e0d1223c0db3aa2067f244f34c1ba.1708288190.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:12 p.m. UTC
* gnu/packages/crates-io.scm (rust-oneshot-uniffi-0.1): Add variable.

Change-Id: I4396a88b687af2ef9e546f4d073cf4a1be0f8f36
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 930e657ce3..1f638fa96b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45007,6 +45007,31 @@  (define-public rust-ogg-0.8
 spec in pure Rust.")
     (license license:expat)))
 
+(define-public rust-oneshot-uniffi-0.1
+  (package
+    (name "rust-oneshot-uniffi")
+    (version "0.1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "oneshot-uniffi" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "175j04f7rpgy552h5m51ywq7184cqhcfs31dsxanjvwpg1f8sm3c"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-development-inputs (("rust-async-std" ,rust-async-std-1)
+                                   ("rust-criterion" ,rust-criterion-0.3)
+                                   ("rust-tokio" ,rust-tokio-1))))
+    (home-page "https://github.com/faern/oneshot")
+    (synopsis
+     "Patched version of oneshot specifically for the UniFFI project.")
+    (description
+     "This package provides a patched version of oneshot specifically for
+the @code{UniFFI} project.  This removes the `loom` target and dependency
+which helps with @code{UniFFI's} downstream consumers.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-onig-6
   (package
     (name "rust-onig")