diff mbox series

[bug#69257,021/228] gnu: Place rust-rpassword-6 in alphabetical order.

Message ID a186ca40ab99eb96860372c014988d48e5cae247.1708288182.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:02 p.m. UTC
gnu/packages/crates-io.scm (rust-rpassword-6): Move variable.

Change-Id: I5f4ea411df53fdfeaf71bcc0dd8639c0c47ab3c7
---
 gnu/packages/crates-io.scm | 38 +++++++++++++++++++-------------------
 1 file changed, 19 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bd4b2f7fe8..3d9779651b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -55442,6 +55442,25 @@  (define-public rust-rowan-0.15
      "This package provides a library for generic lossless syntax trees.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-rpassword-6
+  (package
+    (inherit rust-rpassword-7)
+    (name "rust-rpassword")
+    (version "6.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "rpassword" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0mnrpxvai78mn9wqkqx8wp1gd280jjhn29ixd1dm84l6i2hrkw1b"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-libc" ,rust-libc-0.2)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-winapi" ,rust-winapi-0.3))))))
+
 (define-public rust-rpassword-5
   (package
     (inherit rust-rpassword-6)
@@ -56258,25 +56277,6 @@  (define-public rust-rpassword-7
 console applications.")
     (license license:asl2.0)))
 
-(define-public rust-rpassword-6
-  (package
-    (inherit rust-rpassword-7)
-    (name "rust-rpassword")
-    (version "6.0.1")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "rpassword" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0mnrpxvai78mn9wqkqx8wp1gd280jjhn29ixd1dm84l6i2hrkw1b"))))
-    (arguments
-     `(#:cargo-inputs
-       (("rust-libc" ,rust-libc-0.2)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-json" ,rust-serde-json-1)
-        ("rust-winapi" ,rust-winapi-0.3))))))
-
 (define-public rust-run-script-0.10
   (package
     (name "rust-run-script")