diff mbox series

[bug#69257,067/228] gnu: Add rust-str-stack-0.1.

Message ID b3e205ca3857788a3433e1925aa9c93ac1332546.1708288184.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:03 p.m. UTC
* gnu/packages/crates-io.scm (rust-str-stack-0.1): Add variable.

Change-Id: I288ab5b984139a6bd2c9f3bc53a291a70239d908
---
 gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f61fd50827..85c1558102 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65455,6 +65455,29 @@  (define-public rust-str-buf-1
     (description "This package provides a static string buffer.")
     (license license:boost1.0)))
 
+(define-public rust-str-stack-0.1
+  (package
+    (name "rust-str-stack")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "str_stack" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1sxl8xd8kiaffsryqpfwcb02lnd3djfin7gf38ag5980908vd4ch"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/Stebalien/str_stack")
+    (synopsis
+     "String allocator for allocating many write-once strings")
+    (description
+     "This package provides a string allocator for allocating many write-
+once strings.  This library is primarily useful for parsing where you need
+to repeatedly build many strings, use them, and then throw them away.
+Instead of allocating many independent strings, this library will put them
+all in the same buffer.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-stream-assert-0.1
   (package
     (name "rust-stream-assert")