diff mbox series

[bug#69257,054/228] gnu: Add rust-http-body-1.

Message ID 7ae71290d2cc910170885a9d1dc5c798a18765f5.1708288184.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:02 p.m. UTC
* gnu/packages/crates-web.scm (rust-http-body-1): Add variable.
(rust-http-body-0.4): Inherit rust-http-body-1.

Change-Id: I9616eb39dd18c5a9d9b366a4942614558dca61cc
---
 gnu/packages/crates-web.scm | 33 +++++++++++++++++++++++++--------
 1 file changed, 25 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 6650c26913..b0b431ff88 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2278,8 +2278,32 @@  (define-public rust-http-auth-0.1
 extended with server support and additional auth schemes.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-http-body-1
+  (package
+    (name "rust-http-body")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "http-body" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0hyn8n3iadrbwq8y0p1rl1275s4nm49bllw5wji29g4aa3dqbb0w"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bytes" ,rust-bytes-1)
+                       ("rust-http" ,rust-http-1))))
+    (home-page "https://github.com/hyperium/http-body")
+    (synopsis "Trait representing an asynchronous, streaming, HTTP request
+or response body")
+    (description
+     "This package provides a trait representing an asynchronous, streaming,
+HTTP request or response body.")
+    (license license:expat)))
+
 (define-public rust-http-body-0.4
   (package
+    (inherit rust-http-body-1)
     (name "rust-http-body")
     (version "0.4.6")
     (source
@@ -2289,18 +2313,11 @@  (define-public rust-http-body-0.4
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1lmyjfk6bqk6k9gkn1dxq770sb78pqbqshga241hr5p995bb5skw"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-bytes" ,rust-bytes-1)
-        ("rust-http" ,rust-http-0.2))))
-    (home-page "https://github.com/hyperium/http-body")
-    (synopsis "Asynchronous, streaming, HTTP request or response body")
-    (description
-     "This crate provides a trait representing an asynchronous, streaming,
-HTTP request or response body.")
-    (license license:expat)))
+        ("rust-http" ,rust-http-0.2))))))
 
 (define-public rust-http-body-0.3
   (package