diff mbox series

[bug#69257,189/228] gnu: Add rust-bs58-0.5.

Message ID f96db74c546f28759de21f351999757e3a2d52db.1708288189.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:09 p.m. UTC
* gnu/packages/crates-io.scm (rust-bs58-0.5): Add variable.
(rust-bs58-0.2): Inherit from rust-bs58-0.5.

Change-Id: I06a95ce256d22f0a724abbae9f86db47d9e90483
---
 gnu/packages/crates-io.scm | 45 ++++++++++++++++++++++++++++----------
 1 file changed, 34 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 52add0344c..16d81bd4d5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8141,8 +8141,41 @@  (define-public rust-browserslist-rs-0.6
     (description "Rust-ported Browserslist.")
     (license license:expat)))
 
+(define-public rust-bs58-0.5
+  (package
+    (name "rust-bs58")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "bs58" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "15kqgld75z03srq6nzsdgraakhvap5avgw364h352x0z6hv3ydgm"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-sha2" ,rust-sha2-0.10)
+                       ("rust-smallvec" ,rust-smallvec-1)
+                       ("rust-tinyvec" ,rust-tinyvec-1))
+       #:cargo-development-inputs
+       (("rust-assert-matches" ,rust-assert-matches-1)
+        ("rust-base58" ,rust-base58-0.1)
+        ("rust-criterion" ,rust-criterion-0.3)
+        ("rust-rust-base58" ,rust-rust-base58-0.0)
+        ("rust-tinyvec" ,rust-tinyvec-1))))
+    (home-page "https://github.com/Nullus157/bs58-rs")
+    (synopsis "Another Base58 codec implementation")
+    (description
+     "Another Base58 codec implementation.  Compared to the base58 crate
+this is significantly faster at decoding: about 2.4x as fast when
+decoding 32 bytes, almost the same speed for encoding: about 3% slower
+when encoding 32 bytes. @code{rust-bs58} is not limited to 128 bytes
+and supports a configurable alphabet.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-bs58-0.2
   (package
+    (inherit rust-bs58-0.5)
     (name "rust-bs58")
     (version "0.2.5")
     (source
@@ -8154,23 +8187,13 @@  (define-public rust-bs58-0.2
        (sha256
         (base32
          "125i962x0m0ggdif6ds51wfif2lypiicy469dj5j2l6rm6xycpn9"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-sha2" ,rust-sha2-0.8))
        #:cargo-development-inputs
        (("rust-assert-matches" ,rust-assert-matches-1)
         ("rust-base58" ,rust-base58-0.1)
-        ("rust-rust-base58" ,rust-rust-base58-0.0))))
-    (home-page "https://github.com/mycorrhiza/bs58-rs")
-    (synopsis "Another Base58 codec implementation")
-    (description
-     "Another Base58 codec implementation.  Compared to the base58 crate this
-is significantly faster at decoding (about 2.4x as fast when decoding 32
-bytes), almost the same speed for encoding (about 3% slower when encoding 32
-bytes), doesn't have the 128 byte limitation and supports a configurable
-alphabet.")
-    (license (list license:asl2.0 license:expat))))
+        ("rust-rust-base58" ,rust-rust-base58-0.0))))))
 
 (define-public rust-bson-2
   (package