diff mbox series

[bug#69257,128/228] gnu: Add rust-konst-proc-macros-0.3.

Message ID 3b6ca95f4182882613d29778c3c7242de7eb917f.1708288187.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:08 p.m. UTC
* gnu/packages/crates-io.scm (rust-konst-proc-macros-0.3): Add variable.
(rust-konst-proc-macros-0.2): Move and inherit from
rust-konst-proc-macros-0.3.

Change-Id: I5bdeb05b9f56268cd6ed8d25410f522eecfe8212
---
 gnu/packages/crates-io.scm | 48 ++++++++++++++++++++++++--------------
 1 file changed, 31 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e33247d898..eacdb9a35f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29409,23 +29409,6 @@  (define-public rust-konst-macro-rules-0.2
     (description "Implementation detail of the konst crate.")
     (license license:zlib)))
 
-(define-public rust-konst-proc-macros-0.2
-  (package
-    (name "rust-konst-proc-macros")
-    (version "0.2.11")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "konst_proc_macros" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0dxp8mdh3q9d044ql203way4fgbc50n3j3pi2j1x2snlcaa10klq"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/rodrimati1992/konst/")
-    (synopsis "Implementation detail of the @code{konst} crate")
-    (description "Implementation detail of the @code{konst} crate.")
-    (license license:zlib)))
-
 (define-public rust-human-format-1
   (package
     (name "rust-human-format")
@@ -33058,6 +33041,37 @@  (define-public rust-khronos-api-3
      "The Khronos XML API Registry, exposed as byte string constants.")
     (license license:asl2.0)))
 
+(define-public rust-konst-proc-macros-0.3
+  (package
+    (name "rust-konst-proc-macros")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "konst_proc_macros" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0hv07c8b0v8rlcwkf2n1fv46d5ldk8md344c5c6dc2ayqcfsna2f"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/rodrimati1992/konst/")
+    (synopsis "Implementation detail of the @code{konst} crate")
+    (description "@code{konst-proc-macros} is an implementation detail
+of the @code{konst} crate.")
+    (license license:zlib)))
+
+(define-public rust-konst-proc-macros-0.2
+  (package
+    (inherit rust-konst-proc-macros-0.3)
+    (name "rust-konst-proc-macros")
+    (version "0.2.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "konst_proc_macros" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0dxp8mdh3q9d044ql203way4fgbc50n3j3pi2j1x2snlcaa10klq"))))))
+
 (define-public rust-kqueue-sys-1
   (package
     (name "rust-kqueue-sys")