diff mbox series

[bug#69257,064/228] gnu: rust-sluice-0.5: Update to 0.5.5.

Message ID be432e2767cf39ed92c8a9a8403e89bf3eb5351d.1708288184.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:03 p.m. UTC
From: Efraim Flashner <efraim@flashner.co.il>

* gnu/packages/crates-io.scm (rust-sluice-0.5): Update to 0.5.5.
[cargo-inputs]: Add rust-async-channel-1.  Remove
rust-futures-channel-0.3.
[cargo-development-inputs]: Replace rust-quickcheck-0.9 with 1,
rust-quickcheck-macros with 1.  Remove rust-cfg-if-1.
[synopsis]: Add newline.
[description]: Wrap after 'for'.

Change-Id: Id65bf99f968addbf38496e6d4ca4f180c809e0a3
---
 gnu/packages/crates-io.scm | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2b84618752..f61fd50827 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -63596,31 +63596,31 @@  (define-public rust-slugify-0.1
 (define-public rust-sluice-0.5
   (package
     (name "rust-sluice")
-    (version "0.5.3")
+    (version "0.5.5")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "sluice" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1w9brs9dqyvr2w7cs5nxkp2wggw2xh76bc4qq0p4yxwfvhgfs94f"))))
+        (base32 "1d9ywr5039ibgaby8sc72f8fs5lpp8j5y6p3npya4jplxz000x3d"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
-       (("rust-futures-channel" ,rust-futures-channel-0.3)
+       (("rust-async-channel" ,rust-async-channel-1)
         ("rust-futures-core" ,rust-futures-core-0.3)
         ("rust-futures-io" ,rust-futures-io-0.3))
        #:cargo-development-inputs
-       (("rust-cfg-if" ,rust-cfg-if-1)
-        ("rust-criterion" ,rust-criterion-0.3)
+       (("rust-criterion" ,rust-criterion-0.3)
         ("rust-futures" ,rust-futures-0.3)
-        ("rust-quickcheck" ,rust-quickcheck-0.9)
-        ("rust-quickcheck-macros" ,rust-quickcheck-macros-0.9))))
+        ("rust-quickcheck" ,rust-quickcheck-1)
+        ("rust-quickcheck-macros" ,rust-quickcheck-macros-1))))
     (home-page "https://github.com/sagebind/sluice")
-    (synopsis "Ring buffer for byte buffers, FIFO queues, and SPSC channels")
+    (synopsis
+      "Ring buffer for byte buffers, FIFO queues, and SPSC channels")
     (description
-     "This package provides asynchronous byte buffers and pipes for concurrent
-I/O programming.")
+     "This package provides asynchronous byte buffers and pipes for
+concurrent I/O programming.")
     (license license:expat)))
 
 (define-public rust-smallbitvec-2