diff mbox series

[bug#69257,043/228] gnu: Add rust-etherparse-0.13.

Message ID e863b613ae1276f4a6302221137b49acf1dd62ee.1708288183.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:02 p.m. UTC
* gnu/packages/crates-io.scm (rust-etherparse-0.13): Add variable.

Change-Id: Id8b94bc93cf33f960fedac655ad8f61d95a8a765
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 382190cea0..da2a6bdbef 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22159,6 +22159,31 @@  (define-public rust-etcetera-0.8
 they follow.  Etcetera, on the other hand, gives you the choice.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-etherparse-0.13
+  (package
+    (name "rust-etherparse")
+    (version "0.13.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "etherparse" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "146rcbnhlpcbl6c6csfhvz0227wbiwhk13md6acq8211b7m94wl2"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-arrayvec" ,rust-arrayvec-0.7))
+       #:cargo-development-inputs (("rust-assert-matches" ,rust-assert-matches-1)
+                                   ("rust-proptest" ,rust-proptest-1))))
+    (home-page "https://github.com/JulianSchmid/etherparse")
+    (synopsis
+     "Library for parsing & writing packet based protocols: EthernetII,
+IPv4, IPv6, UDP, TCP, etc.")
+    (description
+     "This package provides a library for parsing & writing a bunch of
+packet based protocols: @code{EthernetII}, IPv4, IPv6, UDP, TCP, etc..")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-evdev-0.12
   (package
     (name "rust-evdev")