diff mbox series

[bug#69257,206/228] gnu: Add rust-fallible-iterator-0.3.

Message ID 5acff5e6a67f356fa653f30eae395185e020d1e9.1708288190.git.herman@rimm.ee
State New
Headers show
Series WIP: Add GNOME Fractal dependencies. | expand

Commit Message

Herman Rimm Feb. 18, 2024, 9:12 p.m. UTC
* gnu/packages/crates-io.scm (rust-fallible-iterator-0.3): Add variable.
(rust-fallible-iterator-0.2): Inherit from rust-fallible-iterator-0.3.

Change-Id: I305faf2dcb65e2af665f778c1a429126a4e4bcf8
---
 gnu/packages/crates-io.scm | 32 ++++++++++++++++++++++----------
 1 file changed, 22 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a0fbcf7028..a3766215a1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -23124,8 +23124,29 @@  (define-public rust-failure-derive-0.1
     (description "Derives for the failure crate.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-fallible-iterator-0.3
+  (package
+    (name "rust-fallible-iterator")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fallible-iterator" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0ja6l56yka5vn4y4pk6hn88z0bpny7a8k1919aqjzp0j1yhy9k1a"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/sfackler/rust-fallible-iterator")
+    (synopsis "Fallible iterator traits")
+    (description "If the @code{std} or @code{alloc} features are enabled, this
+crate provides implementations for @code{Box}, @code{Vec}, @code{BTreeMap}, and
+@code{BTreeSet}.  If the @code{std} feature is enabled, this crate additionally
+provides implementations for @code{HashMap} and @code{HashSet}.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-fallible-iterator-0.2
   (package
+    (inherit rust-fallible-iterator-0.3)
     (name "rust-fallible-iterator")
     (version "0.2.0")
     (source
@@ -23135,16 +23156,7 @@  (define-public rust-fallible-iterator-0.2
         (file-name (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "1xq759lsr8gqss7hva42azn3whgrbrs2sd9xpn92c5ickxm1fhs4"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/sfackler/rust-fallible-iterator")
-    (synopsis "Fallible iterator traits")
-    (description "If the @code{std} or @code{alloc} features are enabled, this
-crate provides implementations for @code{Box}, @code{Vec}, @code{BTreeMap}, and
-@code{BTreeSet}.  If the @code{std} feature is enabled, this crate additionally
-provides implementations for @code{HashMap} and @code{HashSet}.")
-    (license (list license:asl2.0
-                   license:expat))))
+          "1xq759lsr8gqss7hva42azn3whgrbrs2sd9xpn92c5ickxm1fhs4"))))))
 
 (define-public rust-fallible-streaming-iterator-0.1
   (package