diff mbox series

[bug#70855,88/92] gnu: python-qemu-qmp: Improve package style.

Message ID 20240509225530.24649-88-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/virtualization.scm (python-qemu-qmp):
  [arguments]<#:phases>: Rewrite check phase replacement to only run
  tests/protocol.py and not quality-checks.

Change-Id: I3485e2ee10d46b1699674f506876e7c185674653
---
 gnu/packages/virtualization.scm | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index c886c7489a7..0b46281050d 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -2023,13 +2023,11 @@  (define-public python-qemu-qmp
       #~(modify-phases %standard-phases
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                ;; The Avocado test runner insists on writing stuff to HOME.
-                (setenv "HOME" "/tmp")
-                ;; The mypy tests fail (see:
-                ;; https://gitlab.com/jsnow/qemu.qmp/-/issues/1).
-                (delete-file "tests/mypy.sh")
-                (invoke "avocado" "--show=all" "run" "tests")))))))
+              (if tests?
+                  (begin  ; avocado insists on writing stuff to HOME.
+                    (setenv "HOME" "/tmp")
+                    (invoke "avocado" "--show=all" "run" "tests/protocol.py"))
+                  (format #t "test suite not run~%")))))))
     (native-inputs
      (list python-avocado-framework
            python-setuptools-scm