diff mbox series

[bug#70855,31/92] gnu: python-nbval: Move to pyproject-build-system.

Message ID 20240509225530.24649-31-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-check.scm (python-nbval):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Move <#:phases> check phase replacement into proper
  <#:test-flags>.
  [propagated-inputs]: Add python-coverage which should have been
  there.

Change-Id: I93aa282399eb52636ee5561b5d8fb7bb5b93f9e0
---
 gnu/packages/python-check.scm | 48 ++++++++++++++++++-----------------
 1 file changed, 25 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 913fc00ffc5..8e2164a82db 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1574,34 +1574,36 @@  (define-public python-nbval
        (uri (pypi-uri "nbval" version))
        (sha256
         (base32 "0h3xrnw0mj1srigrx2rfnd73h8s0xjycclmjs0vx7qkfyqpcvvyg"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'fix-test
-           (lambda _
-             ;; This test fails because of a mismatch in the output of LaTeX
-             ;; equation environments.  Seems OK to skip.
-             (delete-file
-              "tests/ipynb-test-samples/test-latex-pass-correctouput.ipynb")))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv" "-k"
-                       (string-append
-                        ;; This only works with Pytest < 5.
-                        "not nbdime_reporter"
-                        ;; https://github.com/computationalmodelling/nbval/pull/148.
-                        " and not test_timeouts"
-                        ;; It seems the output format has changed; the following
-                        ;; test fails with "Unexpected output fields from
-                        ;; running code: {'text/plain'}".
-                        " and not test_conf_ignore_stderr "))))))))
+     (list
+      #:test-flags
+      '(list
+        ;; This test fails because of a mismatch in the output of LaTeX
+        ;; equation environments.  Seems OK to skip.
+        "--ignore=tests/ipynb-test-samples/test-latex-pass-correctouput.ipynb"
+        "-k" (string-append
+              ;; This only works with Pytest < 5.
+              "not nbdime_reporter"
+              ;; https://github.com/computationalmodelling/nbval/pull/148.
+              " and not test_timeouts"
+              ;; It seems the output format has changed; the following
+              ;; test fails with "Unexpected output fields from
+              ;; running code: {'text/plain'}".
+              " and not test_conf_ignore_stderr "))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'fix-test
+            (lambda _
+              ;; This test fails because of a mismatch in the output of LaTeX
+              ;; equation environments.  Seems OK to skip.
+              (delete-file "tests/\
+ipynb-test-samples/test-latex-pass-correctouput.ipynb"))))))
     (native-inputs
      (list python-pytest python-pytest-cov python-sympy))
     (propagated-inputs
      (list python-ipykernel python-jupyter-client python-nbformat
-           python-six))
+           python-six python-coverage))
     (home-page "https://github.com/computationalmodelling/nbval")
     (synopsis "Pytest plugin to validate Jupyter notebooks")
     (description