diff mbox series

[bug#70855,37/92] gnu: python-tinycss: Move to pyproject-build-system.

Message ID 20240509225530.24649-37-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-web.scm (python-tinycss):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:test-flags>: Ignore failing test.

Change-Id: I972a3c6390df5f8af79c952292db8a4e24a4aa33
---
 gnu/packages/python-web.scm | 16 +++-------------
 1 file changed, 3 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index aa04a02bad5..88dc08c18f6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5874,20 +5874,10 @@  (define-public python-tinycss
        (uri (pypi-uri "tinycss" version))
        (sha256
         (base32 "0vkifr595h28ymkjhrswwf0bm23lhznh5f44xyp7x7jy1ssnyc0j"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'disable-flake8-isort
-           ;; Flake8 and isort tests fail.
-           (lambda _
-             (substitute* "setup.cfg" ((" --flake8 --isort") ""))
-             #t))
-         (replace 'check
-           (lambda _
-             ;; Disable failing test.
-             (invoke "python" "-m" "pytest" "-k"
-                     "not test_speedups"))))))
+     (list #:test-flags
+           '(list "-k" "not test_speedups")))
     (native-inputs
      (list python-pytest-cov python-pytest-flake8 python-pytest-isort
            python-pytest-runner))