diff mbox series

[bug#70855,45/92] gnu: python-sphinx-autodoc-typehints: Move to pyproject-build-system.

Message ID 20240509225530.24649-45-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/sphinx.scm (python-sphinx-autodoc-typehints):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Move 'check phase replacement...
  ... to argument <#:test-flags>.

Change-Id: I2b41dffd5ee35442e1bb42f426bff69e17648785
---
 gnu/packages/sphinx.scm | 14 +++++---------
 1 file changed, 5 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index ea643040fbf..195cd63ae61 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1135,9 +1135,12 @@  (define-public python-sphinx-autodoc-typehints
        (sha256
         (base32
          "049dlay21f4bccig31fkbzq2m8v0h6g63p1cn3dxay9q3h0mzgs0"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
+      ;; This test requires to download an objects.inv file
+      ;; from the Sphinx website.
+      #:test-flags '(list "-k" "not test_format_annotation")
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'build 'pretend-version
@@ -1145,14 +1148,7 @@  (define-public python-sphinx-autodoc-typehints
             ;; without the git metadata available, the version string is set to
             ;; '0.0.0'.
             (lambda _
-              (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-vv" "tests"
-                        ;; This test requires to download an objects.inv file
-                        ;; from the Sphinx website.
-                        "-k" "not test_format_annotation")))))))
+              (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version))))))
     (propagated-inputs (list python-sphinx))
     (native-inputs
      (list python-nptyping