diff mbox series

[bug#70855,11/92] gnu: python-django-localflavor: Move to pyproject-build-system.

Message ID 20240509225530.24649-11-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/django.scm (python-django-localflavor):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Rewrite check phase replacement.
             <#:test-flags>: Use it.
  [native-inputs]: Remove them. Not needed with the check phase
  rewrite.

Change-Id: Ie50baab2cb102585ee25e3264e00eebe370f4cb2
---
 gnu/packages/django.scm | 23 ++++++++++-------------
 1 file changed, 10 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 6a373be3592..21099f0ff0f 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -283,20 +283,17 @@  (define-public python-django-localflavor
        (uri (pypi-uri "django-localflavor" version))
        (sha256
         (base32 "0i1s0ijfd9rv2cp5x174jcyjpwn7fyg7s1wpbvlwm96bpdvs6bxc"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (setenv "PYTHONPATH"
-                       (string-append ".:"
-                                      (getenv "GUIX_PYTHONPATH")))
-               (invoke "invoke" "test")))))))
-    (native-inputs
-     (list python-coverage python-invoke python-pytest-django which))
+     (list
+      #:test-flags '(list "--settings=tests.settings" "tests")
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? test-flags #:allow-other-keys)
+              (if tests?
+                  (apply invoke "python" "-m" "django" "test" test-flags)
+                  (format #t "test suite not run~%")))))))
     (propagated-inputs
      (list python-django python-stdnum))
     (home-page "https://django-localflavor.readthedocs.io/en/latest/")