diff mbox series

[bug#70855,13/92] gnu: Add xcffibgen.

Message ID 20240509225530.24649-13-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/xorg.scm (xcffibgen): New variable.

Change-Id: Ibcbacdfdeaa657ec1ded7dcc09c10c7fc2aa6717
---
 gnu/packages/xorg.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 74059a26910..fbe6375818f 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1673,6 +1673,39 @@  (define-public printproto
 network-transparent printing system.")
     (license license:x11)))
 
+(define xcffibgen
+  (package
+    (name "xcffibgen")
+    (version "1.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tych0/xcffib")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0wz6zlaqsmpw7ahaadpd7m5n5c5b2ya30xwsana4j5ljygdvzqp9"))))
+    (build-system haskell-build-system)
+    (native-inputs
+     (list ghc-hunit ghc-test-framework ghc-test-framework-hunit))
+    (inputs
+     (list libxcb
+           ghc
+           ghc-filemanip
+           ghc-split
+           ghc-language-python
+           ghc-attoparsec
+           ghc-either
+           ghc-optparse-applicative
+           ghc-xcb-types))
+    (home-page "https://github.com/tych0/xcffib")
+    (synopsis "Build tool for python-xcbffib bindings")
+    (description
+     "This is an internal package that provides a build tool to
+generate code for the @code{python-xcbffib} package.")
+    (license license:expat)))
+
 (define-public randrproto
   (package
     (name "randrproto")