diff mbox series

[bug#70855,63/92] gnu: python-apprise: Improve package style.

Message ID 20240509225530.24649-63-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-apprise):
  [arguments]: Convert <#:phases>  check replacement into
  <#:test-flags>.

Change-Id: I85c2ebadf65a4f1a7735042e784e56313c3de539
---
 gnu/packages/python-xyz.scm | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2eeecfa644b..0d993fbb208 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -329,12 +329,7 @@  (define-public python-apprise
                          python-wheel))
     (arguments
      (list
-      #:phases #~(modify-phases %standard-phases
-                   (replace 'check
-                     (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-                       (when tests?
-                         (delete-file "test/test_plugin_macosx.py")
-                         (invoke "pytest")))))))
+      #:test-flags '(list "--ignore=test/test_plugin_macosx.py")))
     (home-page "https://github.com/caronc/apprise")
     (synopsis
      "Push notification Python library that works with many platforms")