diff mbox series

[bug#70855,74/92] gnu: python-uqbar: Update to 0.6.9.

Message ID 20240509225530.24649-74-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/graphviz.scm (python-uqbar): Update to 0.6.9.

Change-Id: Iee24cb1c66db162001c618d1f64a9e2406c1dacd
---
 gnu/local.mk                                  |  1 -
 gnu/packages/graphviz.scm                     | 19 ++++-----------
 .../patches/python-uqbar-python3.10.patch     | 23 -------------------
 3 files changed, 5 insertions(+), 38 deletions(-)
 delete mode 100644 gnu/packages/patches/python-uqbar-python3.10.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 9c61039239b..8d0bfd781f8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1835,7 +1835,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-sgmllib3k-assertions.patch	\
   %D%/packages/patches/python-sphinx-prompt-docutils-0.19.patch	\
   %D%/packages/patches/python-typeguard-python3.10.patch	\
-  %D%/packages/patches/python-uqbar-python3.10.patch	        \
   %D%/packages/patches/python-wxwidgets-type-errors.patch	\
   %D%/packages/patches/qtdeclarative-5-disable-qmlcache.patch	\
   %D%/packages/patches/qtdeclarative-disable-qmlcache.patch	\
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index b6c46a9d9ec..2c23b6abd5c 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -201,7 +201,7 @@  (define-public python-pygraphviz
 (define-public python-uqbar
   (package
     (name "python-uqbar")
-    (version "0.5.9")
+    (version "0.6.9")
     (source
      (origin
        (method git-fetch)
@@ -210,20 +210,11 @@  (define-public python-uqbar
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0c573nzpm51qgz2g296f8pw8ys0i3r6daynxk06zagk5l5fgw9ar"))
-       (patches (search-patches "python-uqbar-python3.10.patch"))))
+        (base32 "037qj3rymm6xzdpklddfhmfp2p1bq9fi3jrvxj6gmharphd5z869"))))
     (build-system pyproject-build-system)
-    (arguments
-     (list #:test-flags
-           '(list "tests"
-                  "-k" (string-append
-                        "not test_interpret_code_blocks_02 "
-                        "and not test_find_executable "
-                        "and not test_sphinx_api_1 "
-                        "and not test_sphinx_book_text_cached "
-                        "and not test_sphinx_book_text_uncached "
-                        "and not test_sphinx_book_text_broken_strict"))))
+    (arguments  ; XXX: Disable failing tests.
+     (list #:test-flags '(list "tests" "-k" "not test_find_executable \
+and not test_sphinx_book_text_broken_strict")))
     (native-inputs
      (list graphviz
            python-flake8
diff --git a/gnu/packages/patches/python-uqbar-python3.10.patch b/gnu/packages/patches/python-uqbar-python3.10.patch
deleted file mode 100644
index 164f0c0c64d..00000000000
--- a/gnu/packages/patches/python-uqbar-python3.10.patch
+++ /dev/null
@@ -1,23 +0,0 @@ 
-Since Python 3.10 the output of a CLI program created with argparse
-uses "options" instead of "optional arguments". This behaviour breaks
-the tests in python-uqbar.
-
---- a/tests/test_cli.py
-+++ b/tests/test_cli.py
-@@ -84,7 +84,7 @@ def test_call_help():
- 
-         speak like a cat
- 
--        optional arguments:
-+        options:
-           -h, --help  show this help message and exit
-           --version   show program's version number and exit
-           --loud      be adamant
-@@ -101,6 +101,6 @@ def test_help():
-         """
-         usage: vox-aggregator [-h] [--version] {help,list,birds,mammals} ...
- 
--        optional arguments:
-+        options:
-           -h, --help            show this help message and exit
-           --version             show program's version number and exit