diff mbox series

[bug#70855,70/92] gnu: python-cmd2: Move to pyproject-build-system.

Message ID 20240509225530.24649-70-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/python-xyz.scm (python-cmd2):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Remove check phase replacement.
  <#:test-flags>: Add field.

Change-Id: I55b4134fb6caa4af1a4988934043487fa85f9b9b
---
 gnu/packages/python-xyz.scm | 14 +++-----------
 1 file changed, 3 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0cfb1dfd45d..9639b1027b5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31721,18 +31721,10 @@  (define-public python-cmd2
        (sha256
         (base32
          "0h1naik558qh48gx2iyy0a0khvw5fz0in69y84mbrhsm9nq7w3bm"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (if tests?
-                 (invoke "pytest" "-vv" "-k"
-                         ;; These tests fail because no EDITOR is in PATH.
-                         "not test_find_editor_not_specified \
-and not test_transcript")
-                 (format #t "test suite not run~%")))))))
+     (list #:test-flags '(list "-k" "not test_find_editor_not_specified \
+and not test_transcript")))
     (propagated-inputs
      (list python-attrs python-colorama python-pyperclip python-wcwidth))
     (native-inputs